Bug report #16025

[macOS] Control feature rendering order will crash QGIS

Added by Liangxu Wang almost 2 years ago. Updated 25 days ago.

Status:Closed
Priority:High
Assignee:Peter Petrik
Category:mac_os_specific
Affected QGIS version:2.18.14 Regression?:No
Operating System:macOS Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes

Description

When use the "Control feature rendering order" in QGIS 2.18 on mac OSX sierra, it will be crashed.

Reproduce:
1. Add the csv file as a layer, ( with header, wgs 84)
2. In the Layer style dialog, check the "Control feature rendering order", define the order express, choose "count"
3. Click the Apply or OK button

I have tried:
1. Convert the csv file to shape file, crashed.
2. Sort the csv file with count column, crashed.
3. Decrease some lines of the csv file (about ~500 lines, total 30.5K lines), not crashed. Maybe memory problems?

qgis-test-crash.csv Magnifier - Crashed version (1010 KB) Liangxu Wang, 2016-12-31 01:12 PM

qgis-test.csv Magnifier - Not crashed version (997 KB) Liangxu Wang, 2016-12-31 01:29 PM

History

#1 Updated by Liangxu Wang almost 2 years ago

I have tried import the csv data into postgis, and load data from postgis, qgis would be crashed too.

#2 Updated by Giovanni Manghi almost 2 years ago

  • Subject changed from Control feature rendering order will crash QGIS to [macOS] Control feature rendering order will crash QGIS
  • Category set to Data Provider/Delimited Text
  • Priority changed from Normal to High
  • Affected QGIS version changed from 2.18.0 to 2.18.2

Confirmed on macOS (also Sierra here) but not on other platforms.

#3 Updated by Giovanni Manghi over 1 year ago

  • Category changed from Data Provider/Delimited Text to Vectors

#4 Updated by Giovanni Manghi over 1 year ago

  • Regression? set to No
  • Easy fix? set to No

#5 Updated by Martin Koppenhöfer 12 months ago

I can confirm this bug (crashing when "control feature rendering order" is activated) also for Mac OS High Sierra (10.13.1) and both, QGIS 2.14.20-1 and QGIS 2.18.14-1 (both are current releases from kyngchaos). I also suppose it is a memory issue, because it doesn't happen (so far) when zoomed in (few features visible).

#6 Updated by Giovanni Manghi 12 months ago

  • Affected QGIS version changed from 2.18.2 to 2.18.14
  • Description updated (diff)

#7 Updated by Denis Rouzaud 2 months ago

  • Category changed from Vectors to mac_os_specific

#8 Updated by Peter Petrik about 1 month ago

  • Assignee set to Peter Petrik

#9 Updated by Peter Petrik about 1 month ago

unable to reproduce with QGIS 3.3 (375afe5beaf5a17768f4898401a8d76ee4af3878) on MacOS Mojave 10.14.0

#10 Updated by Giovanni Manghi about 1 month ago

  • Status changed from Open to Feedback

#11 Updated by Denis Rouzaud 30 days ago

reporter specifies QGIS 2.18.
I guess it'll be a won't fix?

#12 Updated by Liangxu Wang 25 days ago

Confirmed that it is ok in QGIS 3.2.

#13 Updated by Nyall Dawson 25 days ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF