Bug report #16009

WFS layers cannot be loaded anymore on QGIS 2.18.*

Added by Giovanni Manghi over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Even Rouault
Category:Web Services clients/WFS
Affected QGIS version:2.18.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:23924

Description

layers from

http://www.igeo.pt/WFS/Ambiente/MassasAgua

are loaded empty on QGIS 2.18.* while they load ok on 2.14.*.

Notice that on 2.14.* the only CRS available (as expected) for such layers is 3763. On 2.18.* it shows also 4326. Manually changing the CRS to 3763 does not workaround the problem.

History

#1 Updated by Even Rouault over 2 years ago

  • Assignee set to Even Rouault

#2 Updated by Even Rouault over 2 years ago

Fixed in master 6de4fceec285ab3f271b2ff6d6bf209dd6fface0 and release-2_18 in e0d7374fc9e89620217a898fc199484f7e107454

#3 Updated by Even Rouault over 2 years ago

  • Resolution set to fixed/implemented
  • % Done changed from 0 to 100

Note: after the fix, you need to explicitly select EPSG:3763 since there seems to be a problem with the server with EPSG:4326

#4 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF