Bug report #15996

Problem with thousands separator in composer numeric scalebar

Added by Pedro Venâncio over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.18.0 Regression?:No
Operating System:Windows / Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23912

Description

After a recent update, there is a problem with numeric scalebar thousands separator. My OS regional settings has the point as thousands separator and comma as decimal separator, but numeric scalebar shows comma as thousands separator.

Everything ok with canvas numeric scale.

I've updated today from 2.18.1 to 2.18.2, with OSGeo4W 64bits. Before this, it worked fine, so it sounds like a regression.

I've tried with an old standalone QGIS instalation, in the same computer, and it is ok.

I'm facing with the same problem in Linux (2.18.1+git20161213+7e40fb4+24xenial).

composer_scale_2.jpg - composer numeric scale (38.7 KB) Pedro Venâncio, 2016-12-21 03:38 PM

canvas_scale.jpg - canvas scale (3.3 KB) Pedro Venâncio, 2016-12-21 03:38 PM

History

#2 Updated by Pedro Venâncio over 3 years ago

  • Status changed from Open to Closed

Ok, I've found that this is caused by Rasor FloodMap plugin: https://plugins.qgis.org/plugins/rasor_floodMap

Sorry for the noise here.

Also available in: Atom PDF