Bug report #15948

Deleting all nodes of a single geometry does not delete feature

Added by R. R. almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:2.18.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:23864

Description

Deleting all nodes of a single geoemtry does not delete the feature (see screencast). Is this the expected behaviour for single geometries?

15948.mp4 (1.19 MB) R. R., 2016-12-07 02:16 PM

History

#1 Updated by Nyall Dawson almost 4 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

It's by design - that's why the messagebar gives the hint that the geometry has been cleared and can be readded if desired.

Also available in: Atom PDF