Bug report #15883

Rotate Point Symbols not working

Added by Andre Jesus almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:2.18.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:23801

Description

Case 1: Working
1. Create new feature
2. Rotate symbol using Rotate Point Symbols
3. Save Layers Edits

Case 2: Not Working
1. Create new feature
2. Save Layers Edits (rotate angle is null)
3. Toggle Editing
4. Rotate symbol using Rotate Point Symbols
5. Save Layers Edits

Case 3: Working
1. Toggle Editing
2. Rotate already existing and rotated symbol using Rotate Point Symbols
3. Save Layers Edits

Rotate Point Symbols only works when creating or editing a existing rotated feature but not when editing an existing one if the original rotation value is null.

QGIS 2.8.6 tested and fully working.

History

#1 Updated by Nyall Dawson almost 3 years ago

  • Status changed from Open to Feedback

Works correctly here (using a shapefile). Can you do some more digging to see exactly what triggers this, or share a project & data file demonstrating the issue?

#2 Updated by Andre Jesus almost 3 years ago

Yes, you are right. Yesterday I tested Shapefiles and SQLite and both worked fine.

So, today I recreated all (spatial) indexes and it seems to correct the problem. I can't think the reason It worked tho...

Data source: MS SQL Server 2016.

#3 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Also available in: Atom PDF