Bug report #15854

wmts servers shouldn't re-try 4xx http responses

Added by Calvin Metcalf about 4 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23772

Description

if a tile is inside the bounding box of a layer on a wmts service but the server responded to a getTile request with a 4xx type error message (i.e. 404 or 403) qgis will retry the tile request. This is likely caused by ambiguity in the wmts spec which neglects to specify what should happen if non rectangular bounding boxes were to exist, but the best thing for qgis to do would be to follow what the http error codes suggest and not retry requests that will fail again.

Associated revisions

Revision 171dfe11
Added by Martin Dobias almost 4 years ago

Retry WMS/WMTS/XYZ requests only on timeout (fixes #15854)

It does not really make sense to retry if server returns 404 Not Found or similar...

History

#1 Updated by Martin Dobias almost 4 years ago

  • Status changed from Open to Closed

#2 Updated by Jürgen Fischer about 3 years ago

  • Category set to Unknown

Also available in: Atom PDF