Bug report #15778

red crosses appear after converting delimited text layer with pie charts to shapefile

Added by Renate Wesselingh about 4 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:2.14.3 Regression?:No
Operating System:Mac OS X Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:23699

Description

I have been importing my data using a csv file, which works without problems. I have then been able to make pie charts to display my data, still working in the delimited text layer, using Diagrams in the Layer Properties. But since the attributes table of a delimited text layer cannot be modified, I saved the layer as a shapefile. However, this introduced an extra set of markers that I could not get rid of: red crosses appear at the coordinates of each point and they did not want to go away. This also happened when I imported my data using the GeoCSV plugin. I have found a workaround to avoid getting red crosses: if I save the delimited text layer as a shapefile pretty much directly after importing it, at least before activating Diagrams, the red crosses do not appear after saving the layer as a shapefile. So it seems that this bug is related to having a √ in the Show Diagrams checkbox. Unchecking this box in the delimited text layer before saving as a shapefile also works to avoid getting the crosses, but then all the information about the assigned attributes (names, colours) and all other properties (size, placement) is lost, so it basically means that I have to do the work all over again after conversion.

Screen_Shot_2016-10-07_at_16.39.03.png - screen shot of pie charts with red crosses (83 KB) Renate Wesselingh, 2016-10-28 07:39 AM

History

#1 Updated by Nyall Dawson about 4 years ago

  • Status changed from Open to Feedback

Looks like your layer is in edit mode. Try switching that off

#2 Updated by Giovanni Manghi almost 4 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback, please reopen if necessary.

#3 Updated by Jürgen Fischer about 3 years ago

  • Category set to Unknown

Also available in: Atom PDF