Bug report #15760

can't save colours in colour picker

Added by Donovan Cameron almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Nyall Dawson
Category:Symbology
Affected QGIS version:2.18.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23682

Description

I can't seem to get colours to save in the drag and drop boxes in colour chooser windows. Also tried to use the -> (right arrow button) to assign the colour to a box.

When I close the window, and go to choose a saved colour and apply it to something those saved colour boxes are empty.

I've attached pictures to illustrate it.

I tried to save the colour and click OK to close the properties window then open it again but no dice.

01_-_colour_saved_to_box.png (93.5 KB) Donovan Cameron, 2016-10-26 10:02 AM

02_-_colour_saved_to_box_is_gone.png (19.6 KB) Donovan Cameron, 2016-10-26 10:02 AM

Associated revisions

Revision 520b94e4
Added by Nyall Dawson almost 4 years ago

Fix can't save custom colours in color picker (fix #15760)

Also fixes a memory leak caused by color picker widget not
being deleted

History

#1 Updated by Nyall Dawson almost 4 years ago

  • Assignee set to Nyall Dawson

Confirmed

#2 Updated by Nyall Dawson almost 4 years ago

  • Priority changed from Normal to Severe/Regression

#3 Updated by Nyall Dawson almost 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF