Bug report #15721

WFS 2.0 does not use srsDimension

Added by Thibault Coupin over 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WFS
Affected QGIS version:2.18.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:23643

Description

The WFS service of French National Institute of Geographic and Forest Information (IGN-F) provide some geometry with an altitude.

<BDTOPO_BDD_WLD_WGS84G:the_geom>
  <gml:MultiCurve srsDimension="3" srsName="urn:ogc:def:crs:EPSG::4326">
    <gml:curveMember>
      <gml:LineString srsDimension="3">
        <gml:posList>48.2012911 -3.1509894 276.5 48.2011541 -3.1508829 275.4 48.2010451 -3.1508094 274.9 48.2009594 -3.1507913 273.7</gml:posList>
      </gml:LineString>
    </gml:curveMember>
  </gml:MultiCurve>
</BDTOPO_BDD_WLD_WGS84G:the_geom>

QGIS 2.16 & WFS 2.0 does not understand the srsDimension="3" and use the altitude as a coordinate (see screenshot).
When I do a GetFeature by hand and add in QGIS, the geometry is well displayed.

When I force version 1.0 or 1.1 of WFS, there is no problem.

qgis.png - screen shot (661 KB) Thibault Coupin, 2016-10-18 11:56 PM

Associated revisions

Revision b8616ec5
Added by René-Luc ReLuc almost 3 years ago

Merge pull request #4898 from tcoupin/master

Fix srsDimension parsing in GML, fixes #15721

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Category set to Web Services clients/WFS
  • Status changed from Open to Feedback

Why tagging this as regression? did it worked as expected in previous qgis releases? cheers!

#2 Updated by Thibault Coupin over 3 years ago

I use this tag for severe not for regression.
I follow the documentation : Severe/Regression: a bug that makes QGIS totally unusable, causes serious data loss or a regression from a previous QGIS version

Currently, IGN-F WFS service is unsuable since the autodetection choose version 2.0 of WFS.

#3 Updated by Thibault Coupin over 3 years ago

Same behavior on 2.18.0

#4 Updated by Nyall Dawson over 3 years ago

  • Priority changed from Severe/Regression to High

Doesn't classify as severe. Annoying, but not severe.

#5 Updated by Giovanni Manghi over 3 years ago

  • Affected QGIS version changed from 2.16.3 to 2.18.0
  • Status changed from Feedback to Open
  • Priority changed from High to Normal

#6 Updated by Giovanni Manghi about 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#8 Updated by Giovanni Manghi almost 3 years ago

  • Description updated (diff)
  • Status changed from Open to In Progress
  • Pull Request or Patch supplied changed from No to Yes

#9 Updated by René-Luc ReLuc almost 3 years ago

  • Resolution set to fixed/implemented

#10 Updated by René-Luc ReLuc almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

#11 Updated by René-Luc ReLuc almost 3 years ago

Backport done 21e3e8357abdb3ffa3db487feb7f44b4d9f8a00d

Also available in: Atom PDF