Bug report #15651

Processing merge vector layers returns incomplete result

Added by Giovanni Manghi almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:2.18.4 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:23574

Description

Merging the shapefiles in the attached zip file with the "merge vector layers" from Processing the output is incomplete.

The same operation done with the same tool from "ftools" (so until 2.14.* but no more available in 2.16.*) the result is correct.

merge.zip (52 KB) Giovanni Manghi, 2016-10-02 07:35 PM

split.zip (229 KB) Giovanni Manghi, 2016-10-02 07:35 PM

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Affected QGIS version changed from 2.16.3 to 2.18.4

#2 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to Yes

#3 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Severe/Regression to High

#4 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No

#5 Updated by Alexander Bruy over 2 years ago

  • Description updated (diff)
  • Status changed from Open to Feedback

Seems works fine with latest 2.18. Can you retest?

#6 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Alexander Bruy wrote:

Seems works fine with latest 2.18. Can you retest?

confirmed!

Also available in: Atom PDF