Bug report #15637

ArcGIS MapServer Services Export not working

Added by Tomasz Nycz almost 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/ArcGIS
Affected QGIS version:2.16.3 Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23560

Description

In Add ArcGIS MapServer Layer window, there's Export button. Suddenly doesn't work as suspected. I have defined some services, and now should be possible to export them. But list of defined services is from WFS, not ArcGIS MapServer. In that way, cannot save and share this resources.

Zaznaczenie_007.jpg - Export window (16.7 KB) Tomasz Nycz, 2016-09-29 04:20 AM

Menu_005.jpg - List of predefinied ArcGIS services (6.98 KB) Tomasz Nycz, 2016-09-29 04:20 AM

Associated revisions

Revision 1c2f0de9
Added by Martin Dobias almost 4 years ago

Hide import/export buttons for arcgis services as they do not work (fixes #15637)

Revision 629ca8b9
Added by Martin Dobias almost 4 years ago

Hide import/export buttons for arcgis services as they do not work (fixes #15637)

(cherry picked from commit 1c2f0de9fbea8e90c9d20036bfa1601c1d192a89)

History

#1 Updated by Tomasz Nycz almost 4 years ago

Ubuntu 16.04, QGIS 2.16.3

#2 Updated by Randal Hale almost 4 years ago

Confirmed on 2.17 Master on Ubuntu 16.04

#3 Updated by Martin Dobias almost 4 years ago

  • Status changed from Open to Closed

#4 Updated by Martin Dobias almost 4 years ago

Turns out the support for import/export of connections for arc rest services was never there, so for the meanwhile I have just removed those buttons in the respective dialogs to avoid confusion.

#5 Updated by Giovanni Manghi over 3 years ago

  • Category changed from 147 to Web Services clients/ArcGIS

Also available in: Atom PDF