Bug report #15604

Accented characters allowed as DBF columns

Added by Paolo Cavallini about 4 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:3.0.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:23527

Description

QGIS desktop accepts accented characters as column names for shapefile dbf, and everything seems to work smoothly.
The same files however are not displayed in QGIS sever when that field is used for classification.
I think they should not be allowed anywhere, but if they are, they should work the same in desktop and server.

History

#1 Updated by Paolo Cavallini about 4 years ago

  • Subject changed from Accented charachters allowed as DBF columns to Accented characters allowed as DBF columns

#2 Updated by Giovanni Allegri about 4 years ago

DBF standard defines ISO8859-1 as the default (and theorically the only accepted) encoding. We should guarantee support at least for this encoding...

#3 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#4 Updated by Paolo Cavallini over 2 years ago

  • Affected QGIS version changed from 2.16.2 to 3.0.0
  • Description updated (diff)

Still true in QGIS 3

#5 Updated by Paolo Cavallini over 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #13487

Also available in: Atom PDF