Bug report #15584

Intersection tool ignores selected features in intersect layer

Added by Frank Sokolic about 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:master Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23508

Description

The Intersection tool ignores features that are selected in the Intersect Layer and performs the intersect on all features in the intersect layer. Selected features in the Input Layer are handled correctly and the intersect is only performed on the selected features in the input layer.

This applies to both Vector > Geoprocessing Tools > Intersection and Processing Toolbox > QGIS geoalgorithms > Vector overlay tools > Intersection.

I feel that this is a regression from the ftools version where selected features in both the Input and Intersect layers are taken into account.

Associated revisions

Revision 7370ade7
Added by Victor Olaya almost 3 years ago

[processing] use only selected features for spatial index

fixes #15584

Revision 90db2464
Added by Victor Olaya almost 3 years ago

[processing] use only selected features for spatial index

fixes #15584

History

#1 Updated by Victor Olaya about 3 years ago

  • Status changed from Open to In Progress

I can confirm that it works like that. Just checked, and the issue seems to be in the spatial index. It is created with all features for the Intersect Layer, instead of just the selected ones.

Should be easy to fix. I will do it and close the ticket when ready.

Thanks!

#2 Updated by Victor Olaya almost 3 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF