Bug report #15578

Pyqgis atlas crash on "render as HTML"

Added by Johannes Eberenz over 3 years ago. Updated 12 months ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.14.5 Regression?:No
Operating System:Linux (Ubuntu) Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:Yes Copied to github as #:23502

Description

I'm using pyqgis to render a composer with atlas. When a text label is set to "render as HTML", the execution crashes. The problem doesn't occur using a simpel composer without Atlas.
The report leads to WebcoreQt:

SegvAnalysis:
Segfault happened at: 0x7f42b4b60126 <_ZN7WebCore19initializeWebCoreQtEv+150>: mov (%rax),%r9
PC (0x7f42b4b60126) ok
source "(%rax)" (0x00000000) not located in a known VMA region (needed readable region)!
destination "%r9" ok
SegvReason: reading NULL VMA

History

#1 Updated by Giovanni Manghi almost 3 years ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Status changed from Open to Feedback
  • Priority changed from Normal to High

What about 2.18.4 or qgis3/master? Still true?

#2 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Feedback to Open
  • Description updated (diff)
  • Subject changed from Pyqgis Atlas crash on "render as HTML" to Pyqgis atlas crash on "render as HTML"

#3 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No
  • Regression? set to No

#4 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Open to Feedback

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#5 Updated by Nyall Dawson 12 months ago

  • Status changed from Feedback to Closed
  • Resolution set to no timely feedback

Also available in: Atom PDF