Bug report #15554

v.net.alloc in processing fails when there are spaces in the layer name

Added by Steven Kay about 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/GRASS
Affected QGIS version:2.16.1 Regression?:No
Operating System:ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:23477

Description

Just had a problem getting v.net.alloc to work in qgis 2.16.1 from processing.

Traced it to the following line in the log...

v.in.ogr min_area=0.0001 snap=-1 input="/home/steven/infoviz7/watersheds/airports" layer=airports 27700 output=tmp14736310937613 --overwrite -o

My layer is called "airports 27700", which contains a space. It looks like the lack of quotes around the layer parameter is what causes it to fail. Renaming the layer to "airports_27700" or "airports27700" works.


Related issues

Duplicates QGIS Application - Bug report #15502: GRASS calls need quoting for file-/layernames Closed 2016-08-30

History

#1 Updated by Anita Graser about 3 years ago

  • Subject changed from v.net.alloc in processing fails when there are spaces are in the layer name to v.net.alloc in processing fails when there are spaces in the layer name

#2 Updated by Alexander Bruy about 3 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Also available in: Atom PDF