Bug report #15549

GDAL 2.1.1: gdalwarp to VRT produces large output file if cropping to cutline

Added by Christoph Candido about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Normal
Assignee:Even Rouault
Category:GDAL Tools
Affected QGIS version:2.16.2 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:23472

Description

During some tests with gdalwarp, i recognized a change between GDAL 1.11.4 and GDAL 2.1.1 regarding the creation of VRT files.
When cropping to a rectangular cutline, the output VRT file is much larger in GDAL 2.1.1 than in GDAL 1.11.4.
The larger size results from an automatic segmentation of the cutline, which produces a lot of additional vertex points.

Using GDAL 1.11.4 the resulting VRT files are much smaller, because there is no cutline segmentation.

Is this behavior intended?
Are there any settings or flags to disable the automatic segmentation?

Best regards and my thanks for your efforts!
Christoph

Austria.png (132 KB) Christoph Candido, 2016-09-09 12:17 AM

Austria_GDAL1.11.4.vrt (3.81 KB) Christoph Candido, 2016-09-09 12:17 AM

Austria_GDAL2.1.1.vrt (40.5 KB) Christoph Candido, 2016-09-09 12:17 AM

History

#1 Updated by Jürgen Fischer about 4 years ago

  • Resolution set to up/downstream
  • Status changed from Open to Closed

The GDAL tracker is at http://trac.osgeo.org/gdal

Also available in: Atom PDF