Bug report #15545

Vertical or horizontal Polyline in Composer doesn't show up (if not selected) and cannot be edited (but exported)

Added by Rudi Uhl about 4 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:2.16.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:23468

Description

I can add polylines to a map composition, but when it's strictly vertical or horizontal it is only displayed while selected (without correct width / color). I cannot edit node items on those lines. It doesn't matter if it consists only of two or more nodes, as long as it's strictly horizontal or vertical (two nodes in a diagonal are no problem). It shows up on PDF exports. I doubt it's a matter of the graphics card because it won't show the nodes when I try to edit it. The behavior starts immediately in the moment I delete the last node of a polyline that used to be not strictly vertical or horizontal but becomes so by deleting the other nodes.

linie1.qgs (13.1 KB) Rudi Uhl, 2016-09-08 02:37 AM

linie1.pdf (6.73 KB) Rudi Uhl, 2016-09-08 02:37 AM

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#2 Updated by Jürgen Fischer about 3 years ago

  • Category set to Unknown

#3 Updated by Nyall Dawson almost 3 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in layouts engine

Also available in: Atom PDF