Bug report #15521

Concave hull broken

Added by Giovanni Manghi about 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:master_2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23445

Description

in QGIS > 2.14

I also think that the tool is missing a parameter to allow group the points, otherwise it will be always computed the CH of all the point of the input dataset.

2016-09-02T12:22:43 2 Uncaught error while executing algorithm
Traceback (most recent call last):
File "/usr/share/qgis/python/plugins/processing/core/GeoAlgorithm.py", line 203, in execute
self.processAlgorithm(progress)
File "/usr/share/qgis/python/plugins/processing/algs/qgis/Delaunay.py", line 88, in processAlgorithm
progress.setPercentage(int(current * total))
AttributeError: 'NoneType' object has no attribute 'setPercentage'

2016-09-02T12:22:43 2 Uncaught error while executing algorithm
Traceback (most recent call last):
File "/usr/share/qgis/python/plugins/processing/core/GeoAlgorithm.py", line 203, in execute
self.processAlgorithm(progress)
File "/usr/share/qgis/python/plugins/processing/algs/qgis/ConcaveHull.py", line 69, in processAlgorithm
delone_triangles = processing.runalg("qgis:delaunaytriangulation", layer, None, progress=None)['OUTPUT']
File "/usr/share/qgis/python/plugins/processing/tools/general.py", line 75, in runalg
alg = Processing.runAlgorithm(algOrName, None, *args, **kwargs)
File "/usr/share/qgis/python/plugins/processing/core/Processing.py", line 304, in runAlgorithm
ret = runalg(alg, progress)
File "/usr/share/qgis/python/plugins/processing/gui/AlgorithmExecutor.py", line 52, in runalg
progress.error(e.msg)
AttributeError: 'NoneType' object has no attribute 'error'

pontos_ch.zip (6.73 KB) Giovanni Manghi, 2016-10-02 05:51 PM

Associated revisions

Revision ee9c684a
Added by Alexander Bruy about 3 years ago

[processing] fix progress reporting (fix #15521)

(cherry picked from commit b14dfa65fe8c5db852bac0899f8aac64b91faada)

Revision d26063c6
Added by Alexander Bruy about 3 years ago

[processing] fix progress reporting (fix #15521)

(cherry picked from commit b14dfa65fe8c5db852bac0899f8aac64b91faada)

Revision 9dfd7b26
Added by Alexander Bruy about 3 years ago

[processing] fix progress reporting (fix #15521)

(cherry picked from commit b14dfa65fe8c5db852bac0899f8aac64b91faada)

Conflicts:
python/plugins/processing/gui/AlgorithmDialogBase.py

Revision 8ac1460d
Added by Alexander Bruy about 3 years ago

[processing] fix progress reporting (fix #15521)

Revision 898addfa
Added by Alexander Bruy about 3 years ago

[processing] avoid division by zero (fix #15521)

History

#1 Updated by Alexander Bruy about 3 years ago

  • Status changed from Open to Closed

#2 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Closed to Reopened
  • File pontos_ch.zip added

Sorry Alex, I have to reopen. On the latest master on osgeo4w:

2016-10-03T01:48:27 1 There were errors executing the algorithm.
2016-10-03T01:48:28 2 Uncaught error while executing algorithm
Traceback (most recent call last):
File "C:/OSGeo4W/apps/qgis-dev/./python/plugins\\processing\\core\\GeoAlgorithm.py", line 203, in execute
self.processAlgorithm(progress)
File "C:/OSGeo4W/apps/qgis-dev/./python/plugins\\processing\\algs\\qgis\\ConcaveHull.py", line 75, in processAlgorithm
counter = 50. / delaunay_layer.featureCount()
ZeroDivisionError: float division by zero

#3 Updated by Alexander Bruy about 3 years ago

  • Status changed from Reopened to Closed

#4 Updated by Piotr Pociask about 3 years ago

Algorithm isn't working because Delaunay triangulation can't handle MultiPoint geometries. I've created pull request that fix this.

Also available in: Atom PDF