Bug report #15515

QGIS crashes when changing color of category styled layer.

Added by Stephane Goldstein almost 4 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:23439

Description

QGIS crashes when changing color of categorized styled vector layer.

Steps to reproduce:
Create a new vector layer (tried with polygon and point)
Add two features with different values.
Style by category.
Try changing the color of one of the categories.
When pressing OK on the color selection window, QGIS crashes.

History

#1 Updated by Nyall Dawson almost 4 years ago

  • Priority changed from Normal to Severe/Regression

Confirmed on master_2 branch

#2 Updated by Nyall Dawson almost 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #15634

#3 Updated by Jürgen Fischer almost 3 years ago

  • Category set to Unknown

Also available in: Atom PDF