Bug report #15514

Updating an expression in diagram seems to not apply to the map

Added by Harrissou Santanna about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Nyall Dawson
Category:Diagrams
Affected QGIS version:master_2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23438

Description

Layer's properties > Diagram
build a diagram with some expressions, Apply
Now change one of the expression and hit apply again. No change is done!
You need to delete this expression and add it again or add a new entry (or remove an existing one) to have the "apply" button work as expected

Associated revisions

Revision 111106c6
Added by Nyall Dawson about 4 years ago

Fix cannot modify diagram attribute expression (fix #15514)

Also clean up some code

Revision 7c46784f
Added by Nyall Dawson about 4 years ago

Fix cannot modify diagram attribute expression (fix #15514)

Also clean up some code

(cherry-picked from 111106c64fcf4288617e65fc160a2b6112606cfc)

Revision 4d452181
Added by Nyall Dawson about 4 years ago

Fix cannot modify diagram attribute expression (fix #15514)

Also clean up some code

(cherry-picked from 111106c64fcf4288617e65fc160a2b6112606cfc)

History

#1 Updated by Nyall Dawson about 4 years ago

  • Assignee set to Nyall Dawson

#2 Updated by Nyall Dawson about 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF