Bug report #15511

processing: singlepart to multipart fails

Added by Giovanni Manghi about 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:master_2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23435

Description

take

https://raw.githubusercontent.com/qgis/QGIS/d0faca16a7e63e8bb0e9382c1b7746e1dfc67e2e/python/plugins/processing/tests/testdata/polys.gml

(make optionally a shape version of it) then try to do a "singlepart to multipart" operation using a column that has empty cells or that does not have records with the same value.

The tool returns an error

Invalid unique ID field

that is also misleading (because the operation really need a field that does not contain unique values).

Please notice also that not always (not with any input layer) the error surface when the attribute has empty cells, but seems to be always the case when the attribute does not have repeated values.

It also seems that has always been the case, at least in processing. In fact in ftools in such cases the operation stopped with

At least two features must have same attribute value!
Please choose another field...

for this reason I'm tagging this as regression, because ftools now is gone and the processing equivalent does not work the same way.

Associated revisions

Revision d393734b
Added by Alexander Bruy about 3 years ago

[processing] correct error message (fix #15511)

Revision f80021ec
Added by Alexander Bruy about 3 years ago

[processing] correct error message (fix #15511)

(cherry picked from commit d393734bd3d368f52271838414a3edbf1d4eb1a5)

Revision d642571b
Added by Alexander Bruy about 3 years ago

[processing] correct error message (fix #15511)

(cherry picked from commit d393734bd3d368f52271838414a3edbf1d4eb1a5)

Revision 53a7010f
Added by Alexander Bruy about 3 years ago

[processing] correct error message (fix #15511)

(cherry picked from commit d393734bd3d368f52271838414a3edbf1d4eb1a5)

History

#1 Updated by Alexander Bruy about 3 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF