Bug report #15490

Modeler calculator don't work when passed raster layer bounds

Added by Goyo D almost 4 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Modeller
Affected QGIS version:2.16.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:23414

Description

When the "max X", "min Y" or "max Y" output values of "Raster layer bounds tool are used in the "Calculator" tool an error is generated:

Error executing algorithm Calculator Wrong formula: NonNone

Using "min X" seems to work well though.

To replicate the problem run the attached model after loading a raster layer. If b, c or d are used in the calculator formula you will get an error.

Happens to me in both stable and master from osgeo4w installer (windows 7 32 bits)

test.model (3.94 KB) Goyo D, 2016-08-25 05:20 AM

History

#1 Updated by Alexander Bruy over 3 years ago

  • Status changed from Open to Feedback

Please test master, it should be fixed.

#2 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by Alexander Bruy about 3 years ago

  • Status changed from Feedback to Closed
  • Description updated (diff)

Closed for the lack of feedback. Please reopen if necessary.

#4 Updated by Giovanni Manghi about 3 years ago

  • Resolution set to not reproducable

Also available in: Atom PDF