Bug report #15489

Moving labels doesn't work when using virtual fields

Added by Jérôme Guélat almost 4 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:2.16.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23413

Description

Steps to reproduce the bug (the same workflow is working when using normal fields):

1. Create 2 new virtual fields (for example xlab and ylab)
2. Fill them with NULL
3. Use the 2 new fields in the data defined placement properties of the labeling options
4. Start editing and try to move a label using the "Move label and diagram tool"

It would be very nice to use virtual fields since label placement is very often project specific. It is not very elegant to create many new fields if the same data is used in different projects.

History

#1 Updated by Nyall Dawson almost 4 years ago

Virtual fields don't work that way - they aren't editable, just a read only evaluated value.

#2 Updated by Giovanni Manghi about 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by Jérôme Guélat about 2 years ago

  • Status changed from Open to Closed

This is now possible using auxiliary storage in QGIS 3

Also available in: Atom PDF