Bug report #15466

Freezes when attempting to edit rule based styles after adding field to table

Added by Patrick Dunford almost 4 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System:Xubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:23392

Description

Using the attached project and layer files
Open the properties of the layer
Go to the Style tab
Select rule based
Try to edit the single rule which is displayed
As soon as you click the edit pencil,the edit dialog is not displayed and the application is frozen. You cannot close the dialog therefore you cannot do anything else except kill.

786a59c

test1.zip (167 KB) Patrick Dunford, 2016-08-19 09:02 PM

History

#1 Updated by Patrick Dunford almost 4 years ago

Not related to adding a field to the table. I restored an earlier copy of the table from backup (without the additional field) and observed same behaviour, unable to edit rules.

Have no problems on 2.16

#2 Updated by Albert Teixido almost 4 years ago

same issue here #15317

#3 Updated by Patrick Dunford over 3 years ago

Still a problem on 2.18.2, but not on 2.99 110ffe2

#4 Updated by Giovanni Manghi over 3 years ago

  • Priority changed from Normal to High

#5 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

duplicate of #15317

#6 Updated by Jürgen Fischer almost 3 years ago

  • Category set to Unknown

Also available in: Atom PDF