Bug report #15462

Mean coordinates does list all attributes

Added by belg4mit - over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:2.18.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:23388

Description

The Weights and Unique ID field selectors are only displaying a limited selection of the attributes in my target layer. In particular, it is excluding the fields that are actually of interest i.e; POP100_RE and ZCTA5CE10 which are of types "POP100_RE,N,10,0" and "ZCTA5CE10,C,5" respectively in the DBase file.

MeanCoord.JPG - Screenshot of problem (323 KB) belg4mit -, 2016-08-19 06:52 AM

Block_ZCTA.zip - Subset of data, showing behavior (138 KB) belg4mit -, 2016-08-22 07:17 AM

MeanCoordFieldFailure-2162.jpg (283 KB) belg4mit -, 2016-09-16 12:16 PM

MeanCoordFieldFailure-21801.jpg (257 KB) belg4mit -, 2016-10-25 06:26 AM

History

#1 Updated by Alexander Bruy over 3 years ago

  • Status changed from Open to Feedback

Can you share sample dataset?

#2 Updated by belg4mit - over 3 years ago

#3 Updated by Alexander Bruy over 3 years ago

I can't reproduce the issue. Field "POP100_RE" listed in both comboboxes. Regarding "ZCTA5CE10" field, it has a "string" datatype and can't be used in calculations.

#4 Updated by belg4mit - over 3 years ago

Was that with 2.16.0? Maybe has it been inadvertently fixed in 2.16.1?

I realize that ZCTA5CE is a string and could not be used for weighting, but it seems reasonable to accept as Unique IDs for partioning.

#5 Updated by belg4mit - over 3 years ago

The problem persists for me after upgrading to 2.16.1-2

#6 Updated by Alexander Bruy over 3 years ago

Still can't reproduce (tested with 2.16.2 and master). As I said before, field "POP100_RE" listed in both comboboxes.

#7 Updated by belg4mit - over 3 years ago

I still have this problem with 2.16.2 on Win10 x64.

I'll also note that the aforementioned text fields are still not available for grouping, something that is perfectly sensible and supported by ArcMap.

#8 Updated by Victor Olaya over 3 years ago

  • Status changed from Feedback to Closed

It is fixed in 75269d6

#9 Updated by belg4mit - over 3 years ago

  • Status changed from Closed to Reopened

I've applied the patch to my installation of 2.16.2 and see no change in behavior;
the population variable is still missing, and both lists present the same options.

#10 Updated by Alexander Bruy over 3 years ago

  • Status changed from Reopened to Closed
  • Resolution set to fixed/implemented

As already said, it is fixed in master

#11 Updated by belg4mit - over 3 years ago

Alexander Bruy wrote:

As already said, it is fixed in master

An as I said, I applied the patch but it had no effect. I've also tried the latest 2.18.0-1, which has the amended file in it. Same null result.

#12 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Reopened to Feedback

belg4mit - wrote:

Alexander Bruy wrote:

As already said, it is fixed in master

An as I said, I applied the patch but it had no effect. I've also tried the latest 2.18.0-1, which has the amended file in it. Same null result.

it works fine here with your data on qgis 2.18 on both Windows and Linux.
My bet is that you have a old Processing folder inside ~/-qgis2/python/plugins and that you have patched the version that is shipped in installers, but the one in the plugins folder masks any other one.

#13 Updated by belg4mit - over 3 years ago

Giovanni Manghi wrote:

belg4mit - wrote:

Alexander Bruy wrote:

As already said, it is fixed in master

An as I said, I applied the patch but it had no effect. I've also tried the latest 2.18.0-1, which has the amended file in it. Same null result.

it works fine here with your data on qgis 2.18 on both Windows and Linux.
My bet is that you have a old Processing folder inside ~/-qgis2/python/plugins and that you have patched the version that is shipped in installers, but the one in the plugins folder masks any other one.

Thank you! That was indeed the problem. Apparently I installed the Processing plugin back in 2.10 or 2.12; FWIW, as can be seen in several of the screenshots, the old plugin did not have algorithm specific icons. Perhaps the installer could detect/warn users about newly integrated/conflicting plugins?

#14 Updated by Alexander Bruy over 3 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF