Bug report #15405

Save as MapInfo .tab fails with Integer64 fields

Added by Even Rouault over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:Even Rouault
Category:Data Provider/OGR
Affected QGIS version:2.16.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:23335

Description

When using "Save As" a MapInfo .tab from a source that has a Integer64 field (for example a shapefile), the Save As fails due to the MapInfo .tab driver not supporting 64 bit fields.

Associated revisions

Revision 400a4d70
Added by Even Rouault over 3 years ago

[QgsVectorFileWriter + OGR provider] Create Integer64 fields as Real fields when output driver doesn't support Integer64

Fix #15405

Revision f8ede277
Added by Even Rouault over 3 years ago

[QgsVectorFileWriter + OGR provider] Create Integer64 fields as Real fields when output driver doesn't support Integer64

Fix #15405

Revision 7c81384a
Added by Even Rouault over 3 years ago

[QgsVectorFileWriter + OGR provider] Create Integer64 fields as Real fields when output driver doesn't support Integer64

Fix #15405

History

#1 Updated by Even Rouault over 3 years ago

  • Status changed from Open to Closed

#2 Updated by Even Rouault over 3 years ago

  • Resolution set to fixed/implemented
  • % Done changed from 0 to 100
  • Target version set to Version 2.16

Also available in: Atom PDF