Feature request #1520

After adding a column for OGR-Layer, column doesn't appear in attribute table

Added by Horst Düster over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Redmine Admin
Category:GUI
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:11580

Description

When I add a column to an OGR layer it is nessecary to drop
and reload the layer from the legend to see the new column.

patchforticket1520.patch Magnifier - Patch for ticket 1520 (380 Bytes) Redmine Admin, 2009-05-13 01:21 PM

History

#1 Updated by Redmine Admin over 10 years ago

Unable to replicate this ticket in my windows machine with qgis 1.1.0, was this fixed with the beata code included to trunk?

#2 Updated by Horst Düster over 10 years ago

Replying to [comment:2 gcontreras]:

Unable to replicate this ticket in my windows machine with qgis 1.1.0, was this fixed with the beata code included to trunk?

The issue is still present.
1. Load a shape layer to QGIS
2. Open Layer Properties->Attributes
3. Toggle editing and add an attribute
4. stop editing and save changes
5. close Layer Properties
6. repeat step 2
=> The new attribute column doesn't exists

To see the column you have to unload and reload the layer.

#3 Updated by Redmine Admin over 10 years ago

Just added a patch in case someone want to check it. If it works correctly I will upload it to trunk.

#4 Updated by Redmine Admin over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Patch applied to trunk in revision 10914

#5 Updated by Redmine Admin over 10 years ago

Sorry, I meant

Also available in: Atom PDF