Bug report #15140

Item snapping in print composer

Added by R. R. over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.14.3 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:23079

Description

When moving an item in the print composer, snapping depends on the width of the border. To me it would be more meaningful to snap to the middle of the border.

15140.mp4 (4.16 MB) R. R., 2016-06-26 01:07 PM

scribus_1_4_6_snapping.mp4 (409 KB) R. R., 2016-06-26 03:01 PM

History

#1 Updated by R. R. over 4 years ago

#2 Updated by Nyall Dawson over 4 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

This is by design, and is the usual behaviour in DTP packages

#3 Updated by R. R. over 4 years ago

Hi Nyall, I can't confirm this for Scribus (see screencast).

#4 Updated by Nyall Dawson over 4 years ago

Maybe not all DTP then ;) more discussion in #8943

#5 Updated by R. R. over 4 years ago

I noticed that the print composers' snapping behaviour differs from Adobe InDesign. When snapping two items with different border widths to a guide in InDesign, their coordinates are the same. This should be the default snapping behaviour in QGIS, too.

Also available in: Atom PDF