Bug report #15111

wfsprovider directory is located in home directory

Added by dr - over 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:Even Rouault
Category:Web Services clients/WFS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23053

Description

If Settings -> Options -> Network -> Cache settings (Directory) is not set explicitly then "wfsprovider" directory is created inside home directory (not in ~/.qgis2/cache).

Associated revisions

Revision f193c4e2
Added by Matthias Kuhn over 3 years ago

Don't put default network cache directory directly in $HOME

Fix #15111

Revision 56514a76
Added by Matthias Kuhn over 3 years ago

Don't put default network cache directory directly in $HOME

Fix #15111

Revision 7182b1b8
Added by Even Rouault about 3 years ago

Properly deal with empty cache/directory in WFS provider, server and globe plugin

Fixes #15111

Revision 41693604
Added by Even Rouault about 3 years ago

Properly deal with empty cache/directory in WFS provider, server and globe plugin

Fixes #15111

Revision 763d97fb
Added by Even Rouault about 3 years ago

Properly deal with empty cache/directory in WFS provider, server and globe plugin

Fixes #15111

History

#1 Updated by Anonymous over 3 years ago

  • Status changed from Open to Closed

#2 Updated by dr - over 3 years ago

  • Status changed from Closed to Reopened

Issue is still present.

#3 Updated by Anonymous over 3 years ago

  • Status changed from Reopened to Closed

#4 Updated by dr - over 3 years ago

  • Status changed from Closed to Reopened

Issue is still present. If I start QGIS with Dash and open WFS layer then I get wfsprovider directory inside my home directory. If I try start QGIS from console (with current working directory for example /), then I cannot open WFS because QGIS trying to create wfsprovider directory inside /.

#5 Updated by Even Rouault about 3 years ago

  • Category set to Web Services clients/WFS
  • Assignee set to Even Rouault

#6 Updated by Even Rouault about 3 years ago

  • Status changed from Reopened to Closed

#7 Updated by Even Rouault about 3 years ago

  • Target version set to Version 2.16

Also available in: Atom PDF