Bug report #15099

algorithm with underscore in layer name does not work

Added by Alain FERRATON over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Victor Olaya
Category:Processing/GDAL
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23041

Description

the algorithm
import vector layer in database (avaible connection)
does not work if the layer's name contains an underscore.
for example: 'localisation_2'

The error message is:
ERROR 1: Could not fetch requested layer 'localisation_2'!

Only with gdal2 (QGIS 2.15-dev)

Associated revisions

Revision c81b14d5
Added by Alexander Bruy over 3 years ago

[processing] replace original layer name with exported in the final OGR command (fix #15099)

Revision 78881d64
Added by Alexander Bruy over 3 years ago

[processing] replace original layer name with exported in the final OGR command (fix #15099)

(cherry picked from commit c81b14d59ec578bf678cab2c71b821de574ac0c3)

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Target version set to Version 2.16
  • Priority changed from Normal to Severe/Regression

Confirmed here, and is a regression.

A question: why in this tool(s) now the path of the input layer (in the resulting ogr2ogr command) point to the temp dir and not to the real place of the file?

#2 Updated by Giovanni Manghi over 3 years ago

  • Subject changed from algorithm with underscore in layer name does not work (gdal2) to algorithm with underscore in layer name does not work

It happens also on Linux with gdal 1.11.*

it seems that when creating the ogr2ogr command, now in master the input file name is stripped of the "_" (and maybe other chars).

#3 Updated by Alexander Bruy over 3 years ago

Giovanni Manghi wrote:

A question: why in this tool(s) now the path of the input layer (in the resulting ogr2ogr command) point to the temp dir and not to the real place of the file?

Because now Processing exports all vector layers into common format, that can be used by all backends and also to use only selected features in external tools which can't handle QGIS selection

#4 Updated by Alexander Bruy over 3 years ago

  • Status changed from Open to Closed

#5 Updated by Giovanni Manghi over 3 years ago

Because now Processing exports all vector layers into common format, that can be used by all backends and also to use only selected features in external tools which can't handle QGIS selection

thanks Alex!

Also available in: Atom PDF