Bug report #1509

Polygon border color is not changed for selected polygons

Added by marisn - over 11 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Map Canvas
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11569

Description

If polygons are set to be displayed without fill, it's impossible to see which one is selected, as border color is not changed.

qgis_select_poly_bug.jpg - How many rectangles are selected? (255 KB) marisn -, 2009-01-24 08:27 AM

History

#1 Updated by Giovanni Manghi about 11 years ago

This is still a bug with QGis 1.2 (rev. 11005, Ubuntu 9.04).

#2 Updated by Magnus Homann about 11 years ago

It's made this way by deisgn, see #239. Perhaps another interior selectioncolor would be appropriate.

#3 Updated by Giovanni Manghi about 11 years ago

Replying to [comment:3 homann]:

Perhaps another interior selectioncolor would be appropriate.

The problem is that changing the density of the fill color, it changes also the transparency/tone of the selection color. In the extreme case, with no fill color, the selection color is 100% transparent.

In general it seems that would be better to the selection color be always the same, otherwise the "selection color" option in "options --> general" loses its meaning.

#4 Updated by dr - over 10 years ago

confirmed

#5 Updated by Martin Dobias over 10 years ago

Fixed for new symbology in 8c7a31d3 (SVN r13323).

#6 Updated by Giovanni Manghi about 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Well,
if this has not been fixed for old symbology until now then I guess it will not be fixed in time when the new symbology will take over definitely.

Also available in: Atom PDF