Bug report #15087

Crash when deleting the last segment of a compoundcurve

Added by Even Rouault almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Even Rouault
Category:Geometry
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes

Description

1. Create a new scratch layer of type polygon
2. Create a geometry made of a straight line, circular string and ending with a 2 point straight line (ie from last point of circular string to beginning of first straight line)
3. Use the node tool to delete the first/last vertex

==> QGIS crashes

Associated revisions

Revision dabc3b16
Added by Even Rouault almost 3 years ago

[Geometry] Fix deleteVertex() for CircularString, CompoundCurve and CurvePolygon

In some situations, deleteVertex() could generate an invalid geometry, causing
later crashes due to unexpected structure.

Fix #15087

History

#1 Updated by Even Rouault almost 3 years ago

  • Status changed from Open to Closed

#2 Updated by Even Rouault almost 3 years ago

  • Target version set to Version 2.16

Also available in: Atom PDF