Bug report #15083

Import Data into Geopackage using DBManager

Added by Randal Hale over 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23025

Description

Data Location: https://www.dropbox.com/sh/n93hx8w7g6z6rv7/AAB2zj75D4oNJCZjDUPiy7Rva?dl=0

QGIS Master: eee599e
gdal: 1.11.3

I think this isn't working right. I think.

So I create a geopackage (test1.gpkg) using the data coast_n83.shp through the "Save As..." Dialogue in QGIS. I then try to import Assisted_Living.shp into the geopackage (using dbmanager) and receive an error: Error 11 Connection to database failed

I also tried several things like dragging and dropping and changing the name etc - can't add data. I converted the Assisted_Living.shp to a geopackage and couldn't get it to copy a table from one geopackage to another - in other words I can't create a geopackage with more than one layer in QGIS.

I can add data using ogr: ogr2ogr -append test1.gpkg Assisted_Living.shp -nln assisted_living

Now that I type all of this - I'm wondering if you can add data or if that's the way it is.

History

#1 Updated by Even Rouault over 3 years ago

Note: the provided link is a File Geodatabase and not the mentionned shapefiles.

Isn't it a duplicate of #14981 ?

#2 Updated by Randal Hale over 3 years ago

Sorry about that: https://www.dropbox.com/sh/h0hck6ngmesbymv/AABaIB1Xw7SS4ZD2gdqdNQhra?dl=0

And it appears this might be a duplicate of 14981 - It appears they are trying to do the same thing I am which is import a shapefile into an existing geopackage.

#3 Updated by Randal Hale over 2 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF