Bug report #15070

GeoPackage connection missing in 'DB Manager'

Added by R. R. almost 4 years ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:end of life
Crashes QGIS or corrupts data:No Copied to github as #:23013

Description

After creating a new GeoPackage layer the database connection in the 'DB Manager' is missing.

geopackage_db_manager.mp4 (381 KB) R. R., 2016-06-18 03:47 PM

History

#1 Updated by Paolo Cavallini over 3 years ago

  • Status changed from Open to Feedback

Could you please check whether this is still valid in QGIS 2.18?
Thanks.

#2 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Feedback to Open

Yes it is still true: QGIS is inconsistent compared to spatialite. When creating a new SL db this is registered as connection, and available in BD manager and trough the "add spatialite layer" button. There is no "add gpkg layer" button and when creating a new gpkg this is not registered as a connection (probably because that button is missing).

For this reason this do not seems a BD Manager issues (where you can manually register a new connection to an existing gpkg).

#3 Updated by Giovanni Manghi almost 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#4 Updated by Giovanni Manghi about 1 year ago

  • Resolution set to end of life
  • Status changed from Open to Closed

Also available in: Atom PDF