Bug report #15066

OGR: Sublayers detected sometimes when not relevant (Polygon/CurvePolygon)

Added by Even Rouault almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:Even Rouault
Category:Data Provider/OGR
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No

Description

When a layer is reported by OGR as having a geometry type of unknown, because it is a mix of polygon and curvepolygon, such as in a GML file, we detect 2 sublayers. This is not really appropriate since we can handle both in a single layer. And by detecting 2 sublayers, we actually have duplicates when rendering.

Associated revisions

Revision 22dfd764
Added by Even Rouault almost 3 years ago

[OGR provider] Avoid considering mix of Polygon and CurvePolygon as 2 sublayers

Fixes #15066

History

#1 Updated by Even Rouault almost 3 years ago

  • Status changed from Open to Closed

#2 Updated by Even Rouault almost 3 years ago

  • Resolution set to fixed/implemented
  • % Done changed from 0 to 100
  • Target version set to Version 2.16

Also available in: Atom PDF