Bug report #15058

Geopackage on Ubuntu 16.04

Added by Randal Hale over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23001

Description

So i'm wondering if this is ultimately a gdal issue (1.11.3 vs 2)

Data in Dropbox: https://www.dropbox.com/sh/h0hck6ngmesbymv/AABaIB1Xw7SS4ZD2gdqdNQhra?dl=0

I have a ESRI File based Geodatabase. I convert it to Geopackage using oogr2ogr -f GPKG hawaii.gpkg HawaiiESI.gdb -skipfailures

On windows QGIS 2.15 version 6035f19 I can add data from the Geopackage using the Add Vector tool (it would be nice to attach to it like you can with spatialite IMO).

On Ubuntu 16.04 I can't see the geopackage using the add vector tool. It is QGIS version 2.15 5458d64

History

#1 Updated by Even Rouault over 3 years ago

This is strange I cannot reproduce your issue although trying exactly the same things. I compiled QGIS master on Ubuntu 16.04 against the default GDAL (1.11.3). I generated the gpkg with "ogr2ogr -f GPKG hawaii.gpkg HawaiiESI.gdb -skipfailures" with the same GDAL, and it opens fine in QGIS master (and in the QGIS 2.8 that comes with the distro as well). I also generated the gpkg with GDAL 2.1, and it opens fine as well in the QGIS master/GDAL 1.11.3.

#2 Updated by Randal Hale over 3 years ago

I didn't compile - I loaded from the apt repositories on deb http://qgis.org/debian-nightly xenial main. Hopefully it's just me. I retried it and it still isn't loading. I'll load the next update to master and see what happens. I didn't get an update last night.

#3 Updated by Even Rouault over 3 years ago

I've just installed qgis 2.15 5458d64 from "deb http://qgis.org/debian-nightly xenial main" and I can still open the .gpkg. Are you sure the issue isn't with the .gpkg you've generated. Does "ogrinfo -ro -al -so hawaii.gpkg" work in a terminal ?

#4 Updated by Randal Hale over 3 years ago

  • Status changed from Open to Closed

So in the meantime since the last update I've reinstalled QGIS 2.15 - and now it's acting as it should. ogrinfo is reading the file (it was before) and now QGIS is seeing everything. I filed another bug report and lemme go check that one now. Even - I appreciate walking through this with me.

Also available in: Atom PDF