Bug report #15041

road graph plugin routing on virtual field

Added by Pieter Brusselman almost 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Analysis library
Affected QGIS version:2.14.3 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22986

Description

According to the documentation the speed field has to be numeric. However when you create a virtual field of the numeric type, it is not recognised by the plugin under vector > road graph > settings.

It would be great that this would be possible, because it gives great flexibility in changing parameters to the speed-field. More info: http://gis.stackexchange.com/questions/198538/road-graph-plugin-routing-on-a-virtual-numeric-field-does-not-work

Associated revisions

Revision 44112675
Added by Nyall Dawson almost 4 years ago

[roadgraph] Allow use of virtual and joined fields (fix #15041)

Also modernise some code

History

#1 Updated by Nyall Dawson almost 4 years ago

  • Status changed from Open to Closed

#2 Updated by Giovanni Manghi over 3 years ago

  • Category changed from 113 to Analysis library

Also available in: Atom PDF