Bug report #15040

Displacement point Symbology: Data defined rotation for subrenderer symbol doesn't work with layer field value

Added by Harrissou Santanna almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.14.3 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:22985

Description

Layer properties > Displacement point rendering
Renderer settings > for the rotation of the symbol, apply a data defined expression using one of the layer's fields
Apply
symbols are rotated but they all follow one direction within a group (seems to be the value of the first point fetched in the group) instead of each symbol following its own value.
Trying an expression like rand (1, 360), each symbol was oriented differently.

History

#1 Updated by Nyall Dawson almost 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #9601

#2 Updated by Harrissou Santanna almost 4 years ago

Oups, sorry...(i've searched though)

Also available in: Atom PDF