Bug report #14992

composer : data defined control over map layer do not work if a layer is filtered.

Added by Alain FERRATON about 4 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:Nyall Dawson
Category:Unknown
Affected QGIS version:2.14.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:22939

History

#1 Updated by Nyall Dawson about 4 years ago

What do you mean by "filtered"?

#2 Updated by Alain FERRATON about 4 years ago

sorry, for my bad english.

Layer Menu -> Filter...

#3 Updated by Nyall Dawson about 4 years ago

  • Status changed from Open to Feedback

I need more details - I can't reproduce. Are you referring to the data defined layers or data defined style preset?
Style presets don't save layer subsets, maybe that's what you're seeing?

#4 Updated by Alain FERRATON about 4 years ago

sorry, I made a mistake.
the feature works correctly.

A proposal for a new feature:
allow filtering on the features of the layer in the control in mapcomposer with an expression
NameLayer | subset = ...

thanks

#5 Updated by Nyall Dawson about 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

No problem! Can you file the request in a new ticket (it's a good idea btw)

#6 Updated by Jürgen Fischer almost 3 years ago

  • Category set to Unknown

Also available in: Atom PDF