Bug report #14989

labelling: cartographic placement broken when data-defined quadrant set

Added by Mathieu Pellerin - nIRV over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:Nyall Dawson
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22937

Description

The labelling's cartographic placement is "broken" when a data-defined quadrant expression is set (even though cartographic placement does not rely on quadrant settings). What should happen here is for quadrant settings to be ignored when in cartographic placement.

Steps to reproduce
  1. Create a new project, add a point layer
  2. Open the labelling settings, and activate labels
  3. set label placement to (*) around point, and add the following data-defined quadrant expression: 3
  4. Apply the settings, you should see labels displayed to the left of your points
  5. Re-open the labelling settings
  6. Set label placement to (*) cartographic, and notice the quadrant data-defined button gone (since it's not used)
  7. Apply the settings, you should see labels still displayed only to the left of your points

Associated revisions

Revision 7c34c537
Added by Mathieu Pellerin - nIRV over 3 years ago

[pal] fix quadrant exp. wrongly overwriting cartographic placement
(fixes #14989)

Revision 3afb05c2
Added by Nyall Dawson over 3 years ago

Merge pull request #3193 from nirvn/pal_fix_quadrant

[pal] fix quadrant exp. wrongly overwriting cartographic placement (fixes #14989)

History

#1 Updated by Nyall Dawson over 3 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF