Bug report #14949

QGIS desktop calls otbApplicationLauncherCommandLine during startup

Added by Victor Poughon almost 4 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/Core
Affected QGIS version:2.14.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:22898

Description

With QGIS 2.14 desktop on Windows, there is high CPU and memory usage from otbApplicationLauncherCommandLine.exe during QGIS splash screen. It looks to be about 100% increase from QGIS load time due to OTB. See attached screenshot.

I could not reproduce with 2.8.1

We are also tracking it on OTB bug tracker: https://bugs.orfeo-toolbox.org/view.php?id=1226

bugqgisotb.png (442 KB) Victor Poughon, 2016-06-02 01:27 AM

History

#1 Updated by Jürgen Fischer almost 4 years ago

  • Category set to 120

#2 Updated by Alexander Bruy almost 4 years ago

Seems this happens because Processing tries to detect OTB version by launching otbcli_Smoothing command. Detecting version is needed to determine folder with algorithms descriptions.

#3 Updated by Victor Poughon almost 4 years ago

Alexander Bruy wrote:

Seems this happens because Processing tries to detect OTB version by launching otbcli_Smoothing command. Detecting version is needed to determine folder with algorithms descriptions.

Could you point me to the processing/QGIS source file where that happens? I can take a look at it. It should be possible to get the version number without using so much ram and time.

#5 Updated by Alexander Bruy about 3 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

Fixed in master (OTB provider is not separate plugin)

#6 Updated by Giovanni Manghi almost 3 years ago

  • Regression? set to No

#7 Updated by Giovanni Manghi almost 3 years ago

  • Easy fix? set to No

#8 Updated by Giovanni Manghi almost 3 years ago

Some providers are being removed from QGIS/Processing (will be available as plugin) and so are their categories in the bug tracker. To not leave them orphaned of a category they are being reassigned to processing/core.

#9 Updated by Giovanni Manghi almost 3 years ago

  • Category changed from 120 to Processing/Core

Also available in: Atom PDF