Bug report #14936

Add python-future as a dependency

Added by Paolo Cavallini almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:22887

Description

It is now necessary. From Matthias Kuhn:

python-future is a wrapper library that allows maintaining a single
python codebase compatible with python2 and python3.
Having this available in 2.14 is important so during the transition
period to QGIS 3 plugin authors have the possibility to write plugins
that work on the last LTR and work with 3.0 without being required to
maintain two different codebases.


Related issues

Duplicates QGIS Application - Bug report #14577: No python module "future" Closed 2016-03-28

History

#1 Updated by Jürgen Fischer almost 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #14577

Also available in: Atom PDF