Bug report #14885

Layer effect lost when exporting

Added by Magnus Nilsson almost 4 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:2.14.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:22838

Description

I applied some layer effects to a polygon layer, but most of the effects seem to get lost when exporting to JPG, TIFF and PDF. In the attached image, the left part is in QGIS and the right part is from the exported JPG.

QGIS 2.14.0, 64 bit
Windows 7, 64 bit

LayerEffects.jpg (15.8 KB) Magnus Nilsson, 2016-05-25 04:58 AM

Associated revisions

Revision f9810a45
Added by Mathieu Pellerin - nIRV 11 months ago

[effects] Fix blur radius not taking dpi into account (fixes #14885)

Revision 9809c1e4
Added by Mathieu Pellerin - nIRV 11 months ago

[effects] Fix blur radius not taking dpi into account (fixes #14885)

History

#1 Updated by Nyall Dawson almost 4 years ago

  • Status changed from Open to Feedback

Are you using a blur? If so, the blur units are in pixels, so a blur exported to a higher dpi via composer will look smaller then the on-screen version.

#2 Updated by Magnus Nilsson almost 4 years ago

Ah, yes, I use blur and your suggestion helped. Obviously, this is not a bug.

#3 Updated by Nyall Dawson almost 4 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

#4 Updated by Jürgen Fischer over 2 years ago

  • Category set to Unknown

Also available in: Atom PDF