Bug report #14881

Segmentation fault in QWebPage::staticMetaObjectExtraData

Added by Bas Couwenberg about 4 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Python plugins
Affected QGIS version:2.14.3 Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:22834

Description

As reported by Nelson A. de Oliveira in Debian Bug #825091, qgis 2.14.3 segfaults in QWebPage::staticMetaObjectExtraData () when it's built with WITH_QTWEBKIT=FALSE:

With an empty project I loaded a SRTM file, double clicked at GRASS
GIS 7's r.param.scale (in the toolbox) and got a segfault.
It's reproducible.

gdb's "thread apply all bt full" is attached.

This gdb log is attached as: gdb_qgis_2.14.3_grass.txt

And the second report:

I saw that QuickOSM is also segfaulting (gdb output is also attached).

This gdb log is attached as: gdb_qgis_2.14.3_quickosm.txt

I can reproduce the problem by starting qgis and installing the QuickOSM plugin.

The gdb output for this is attached as: gdb_qgis_2.14.3_install-quickosm.txt

Interestingly despite WITH_QTWEBKIT=FALSE used for the build, /usr/lib/python2.7/dist-packages/PyQt4/QtWebKit.so is still in the backtraces.

gdb_qgis_2.14.3_grass.txt Magnifier (134 KB) Bas Couwenberg, 2016-05-24 02:47 PM

gdb_qgis_2.14.3_quickosm.txt Magnifier (206 KB) Bas Couwenberg, 2016-05-24 02:47 PM

gdb_qgis_2.14.3_install-quickosm.txt Magnifier (32.8 KB) Bas Couwenberg, 2016-05-24 02:47 PM

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Priority changed from Normal to High

#2 Updated by Giovanni Manghi over 3 years ago

  • Category set to Python plugins
  • Status changed from Open to Feedback

Cannot see any issue on 2.18.4 on Ubuntu 16.04, using the qgis repositories + ubuntugis.

A clear way to replicate this would be appreciated, thanks.

#3 Updated by Bas Couwenberg over 3 years ago

The report is for QGIS 2.14 on Debian testing using the packages from Debian (not the qgis.org packages).'

`WITH_QTWEBKIT=FALSE` is no longer used for those packages, since the embedded copy in QGIS is used instead.

#4 Updated by Giovanni Manghi over 3 years ago

Bas Couwenberg wrote:

The report is for QGIS 2.14 on Debian testing using the packages from Debian (not the qgis.org packages).'

`WITH_QTWEBKIT=FALSE` is no longer used for those packages, since the embedded copy in QGIS is used instead.

do we care anymore about 2.14 as it will be soon become obsolete and replaced by 2.18 as LTR? genuinely asking.

#5 Updated by Bas Couwenberg over 3 years ago

I still care about QGIS 2.14 since that will be included in Debian stretch.

#6 Updated by Giovanni Manghi over 3 years ago

  • Operating System set to Debian
  • Status changed from Feedback to Open

#7 Updated by Giovanni Manghi about 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#8 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#9 Updated by Bas Couwenberg over 1 year ago

Just close the issue, we did the same with the bugreport in Debian.

#10 Updated by Nyall Dawson over 1 year ago

  • Status changed from Feedback to Closed
  • Description updated (diff)
  • Resolution set to not reproducable

Also available in: Atom PDF