Bug report #14794

Text in svg misaligned in 2.14 composer

Added by David Strausz almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.14.0 Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22751

Description

Starting in version 2.14, an svg that was correctly rendering in previous versions, is now rendering with misplaced text in composer.

I attach a copy of the svg experiencing this issue - NauticalRoseSJ.svg.

This svg was created in Inkscape and saved as a standard svg. It has been working fine in earlier QGIS versions.

I also attach a pdf showing bitmap images of the correct and version 2.14 renderings - QGIS214Render.pdf

Note that the misplaced text is only the text that has been rotated around the rings in the compass rose. The other text seems to be placed as expected.

I noticed this on first upgrading to 2.14.0, and it still persists in current version installed (2.14.2).

Thanks for checking this out.

David Strausz

QGIS214Render.pdf - Example of rendering issue (63.1 KB) David Strausz, 2016-05-09 09:58 AM

NauticalRoseSJ.svg - svg file that exhibits issue when displayed in 2.14 composer (66 KB) David Strausz, 2016-05-09 09:58 AM

Associated revisions

Revision 2265115f
Added by Nyall Dawson almost 4 years ago

Fix issues rendering SVG with text (fix #14644, #14794)

Revision 482140bf
Added by Nyall Dawson almost 4 years ago

Fix issues rendering SVG with text (fix #14644, #14794)

(cherry-picked from 2265115f8003857e538f07287c1337fed463a39c)

History

#1 Updated by Nyall Dawson almost 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF