Bug report #14780

plugin in user plugin dir masks the newer version in core plugins dir in master (2.14 just works)

Added by Richard Duivenvoorde over 3 years ago. Updated 11 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:end of life
Crashes QGIS or corrupts data:No Copied to github as #:22737

Description

After looking into #11187

It looks like the version number is not taken into account by the descision which plugin is the latest and should be loaded.

In this case:
- a newer version (2.12.99) version of processing in $INSTALL/share/qgis/python/plugins/
and
- a (repo) version 2.12.2 in .qgis2/python/plugins/
is hidden.

BUT given the setup above and starting QGIS 2.14, THEN QGIS works ok (aka is loading the 2.12.99 version and showing the menu's)

So it looks like something is changed in master that breaks the version checking?

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No
  • Regression? set to No

#2 Updated by Jürgen Fischer over 2 years ago

  • Category set to Unknown

#3 Updated by Giovanni Manghi 11 months ago

  • Resolution set to end of life
  • Status changed from Open to Closed

Also available in: Atom PDF