Bug report #11187

2.4 install on Ubuntu 14.04. Vector menu missing many items.

Added by Melissa Nunes almost 6 years ago. Updated over 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Processing/Core
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19499

Description

Vector menu no longer had geoprocessing tools. Raster menu also seems to be missing elements.

Has there been a GUI change? Are these tools hiding elsewhere? Google search and documentation dont indicate...

Thanks.

QGis_bug.png (7.62 KB) Simon Dedman, 2016-05-05 10:40 AM

History

#1 Updated by Melissa Nunes almost 6 years ago

Installing via ppa:ubuntugis/ubuntugis-unstable seems to fix problem...

#2 Updated by Matthias Kuhn almost 6 years ago

  • Status changed from Open to Closed

Seems to be fixed.

If there is a reason to reopen: Please state which entries are missing!

#3 Updated by Simon Dedman about 4 years ago

  • File QGis_bug.png added
  • Status changed from Closed to Reopened

I have this problem. Screenshot of my vector menu attached. V2.15 master linux, PPA from debian-nightly wily. Versions from about box:

QGIS version 2.15.0-Master
QGIS code branch Release 2.15
Compiled against Qt 4.8.6
Running against Qt 4.8.6
Compiled against GDAL/OGR 1.11.2
Running against GDAL/OGR 1.11.2
Compiled against GEOS 3.5.0-CAPI-1.9.0
Running against GEOS 3.5.0-CAPI-1.9.0 r4084
PostgreSQL Client Version 9.4.5
SpatiaLite Version 4.3.0
QWT Version 5.2.3
PROJ.4 Version 491
QScintilla2 Version 2.9

#4 Updated by Harrissou Santanna about 4 years ago

Hi,
If you were looking for FTools items, note that FTools has been removed in master and replaced by Processing algorithms. So check if you activate the processing tools in your plugin manager.

#5 Updated by Simon Dedman about 4 years ago

Got it, so these are now in the side panel, QGis geoalorithms, vector geometry tools, voronoi polygons (for example).

Do we know why they were moved out of the top menu? Seems rather unintuitive since raster tools are still up there...

#6 Updated by Harrissou Santanna about 4 years ago

Simon Dedman wrote:

Got it, so these are now in the side panel, QGis geoalorithms, vector geometry tools, voronoi polygons (for example).

Do we know why they were moved out of the top menu? Seems rather unintuitive since raster tools are still up there...

They should still be in the vector menu. And they are, at least on mine. re-check and report, please (unchecking FTools and checking Processing in your plugin Manager)
see https://github.com/qgis/QGIS-Enhancement-Proposals/issues/54 for the reasons.

#7 Updated by Richard Duivenvoorde about 4 years ago

I tried this here on Debian too:

- 2.14.2: OK
- master: no menu
- master started with 'qgis --configpath /tmp/foo': OK

So though at first it seemed something with my configuration (all in .qgis2), it is strange that qgis 2.14 is ok with it, but master apparently no :-(

#8 Updated by Richard Duivenvoorde about 4 years ago

Ok after some investigating this has to do with different versions of the processing plugin in different places.

IF you run master version, then there is a processing plugin included as 'core'-plugin

IF you then also have a processing plugin in your .qgis2/python/plugins it makes the menu dissappear.

Actually the plugin loader should mask the older version (in your plugin folder), but this does not work currently.

So the fix is: IF you are running master: remove the processing from your plugin folder
If you want to run 2.14.x again you should download processing from the plugin repo again

So closing this one I think as it is not ubuntu specific, but actually a plugin loading problem...

#9 Updated by Richard Duivenvoorde about 4 years ago

  • Status changed from Reopened to Closed

#10 Updated by Simon Dedman about 4 years ago

Hi Richard,

Good sleuthing. Are you sure it's right to close this though? It's still a bug no?

I renamed processing to "brocessing" (convenience) in /usr/share/qgis/python/plugins/db_manager but when reloaded, qgis then found v2.12.99 there, and 2.12.2 in /home/me/.qgis2/python/plugins/processing (when looking at the plugins menu). I then moved both processing folders up one level so they wouldn't be found, still no menu, now no processing option in the plugins menu. Fine. Put processing folder back into plugins folder in /user/share, reloaded qgis, no menu, went to plugins menu, turned on processing (2.12.99, newer than in repository), menu is back.

So: fixed, good stuff, thanks. But surely this is a bug? Even if it's not ubuntu specific, it's a plugin loading problem, and qgis should handle this differently/better/correctly.

#11 Updated by Simon Dedman about 4 years ago

  • Status changed from Closed to Reopened

Hi Richard. I had to reinstall Qgis and ran into this again. Even if it is or isn't ubuntu specific, it's still an unresolved bug. And what's odd today is that I had processing in /usr/share but no menu, and since moving it from usr/share, it's now not present in the plugins menu, AND there's no Processing item listed in plugs for me to download...!

#12 Updated by Jürgen Fischer about 4 years ago

  • Category set to Processing/Core

#13 Updated by Alexander Bruy about 4 years ago

  • Status changed from Reopened to Feedback

Simon Dedman wrote:

And what's odd today is that I had processing in /usr/share but no menu, and since moving it from usr/share, it's now not present in the plugins menu

Please check that you have no Processing in your ~/.qgis2/plugins directory

Simon Dedman wrote:

AND there's no Processing item listed in plugs for me to download...!

This is correct. Processing is a core QGIS plugin and shipped only with QGIS

#14 Updated by Simon Dedman about 4 years ago

Please check that you have no Processing in your ~/.qgis2/plugins directory

Processing folders:
/.qgis2/processing/
and
/.qgis2/python/processing/
but not in:
~/.qgis2/python/plugins/

Thanks Alex.

#15 Updated by Alexander Bruy over 3 years ago

  • Status changed from Feedback to Closed

Closed for the lack of feedback. Reopen if necessary

Also available in: Atom PDF