Bug report #14736

Copy from table to Excel/text editor produces bad data

Added by Magnus Nilsson over 4 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Attribute table
Affected QGIS version:2.14.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:22694

Description

Hi
I discovered that QGIS has trouble exporting table data via the clipboard. Steps:

1. Open a table from the layer list
2. Select all
3. Copy
4. Open Excel or a text editor
5. Paste there

The result is the correct number of rows, but all of them containing data from just the first row.

QGIS 2.14.0, 64 bit
Windows 7, 64 bit

History

#1 Updated by Magnus Nilsson over 4 years ago

I should add that this is a virtual layer. Also, doing "Save as..." to a CSV file produces correct output.

#2 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by Nyall Dawson about 3 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed
  • Description updated (diff)

Underlying issue is #16798 - I'll close this as a duplicate because the other ticket has more info

Also available in: Atom PDF