Bug report #1471

The grass requires Qt3 backwards compatibility

Added by vince - over 11 years ago. Updated almost 11 years ago.

Status:Closed
Priority:Low
Assignee:Lorenzo Masini
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11531

Description

It seems that the Grass plugin requires the presence of Q3* classes.
I am not sure the backwards compatibility is still present in Qt 4.5; at any rate, it is going to be discontinued somehow, so it would be nice to enhance the Grass plugin to be QT4 native.

Vincent

History

#1 Updated by Paolo Cavallini over 11 years ago

The shell is now barely usable (see also several shell related bugs, probably related). Raising the priority.

#2 Updated by Paolo Cavallini over 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in 73e86da0 (SVN r10666).

#3 Updated by Paolo Cavallini almost 11 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

#4 Updated by Paolo Cavallini almost 11 years ago

  • Status changed from Feedback to Open

#5 Updated by Paolo Cavallini almost 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF