Bug report #14688

SVG in Layer Properties Crashes QGIS

Added by Randal Hale almost 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:22652

Description

I'm using Ubuntu 15.10 and QGIS 2.14.1

Add a point layer
Go to Properties
Change Simple Marker to SVG
QGIS Crashes

I tested it with Shapefiles and PostGIS just for giggles. Crashed on Both.

History

#1 Updated by R. R. almost 4 years ago

I've tried to reproduce this issue, but everything works as expected.

Ubuntu 14.04 LTS
qgis 1:2.14.1+git20160413+0bde357+20trusty

#2 Updated by Randal Hale almost 4 years ago

I'm going to attempt to reload QGIS 2.14.1 - I just crashed my OSGEO4W install doing the exact same thing.

#3 Updated by Nyall Dawson almost 4 years ago

  • Status changed from Open to Feedback

I suspect this is caused by a malformed svg in your svg library. If you can track down which one is causing it and share then I'm sure we can find a fix...

#4 Updated by Randal Hale almost 4 years ago

I think I figured it out. I had added my /home/rjhale directory as an SVG search directory at some point in the past. I went under settings -> Options -> System and removed /home/rjhale and it stopped crashing. I had no SVG's in /home/rjhale. I did have some png and jpgs. So I'm trying to figure out it one of those as causing an issue. I even re-added /home/rjhale and it's working now. Time to check the two other installs to see what is happening.

#5 Updated by Nyall Dawson almost 4 years ago

Note that the search is recursive, so the SVG may be in a subdirectory

#6 Updated by Becky Wilkes almost 4 years ago

I thought I would chime in here, as I was having a similar problem just this week. In trying to set properties for a point layer, if I tried to change my Simple Marker to an SVG symbol, QGIS would crash. I'm running QGIS LTR 2.8.8 on Windows (64 bit).

I had tried uninstalling and reinstalling QGIS, to no avail. But clearing my SVG path (it had been set to my desktop) under "Settings>Options>System" caused the problem to go away. (Thanks, Randal!)

p.s. From brief tests on a colleague's computer, this problem does NOT seem to occur on a Mac.

#7 Updated by Giovanni Manghi almost 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to not reproducable

I thought it could have a been a path with no SVG in it, but I tested an no crashes.
Please reopen if you find a reliable way to replicate the issue.

#8 Updated by Bernardo Loureiro over 3 years ago

I've encountered the same issue on Mac OS 10.11.6 and QGIS 2.14.3.

As the OP mentioned, the issue is resolved when changing the default SVG search directory from /home/myuser to another folder.

I think the issue might be related to the fact that QGIS tries to search my entire user directory for SVGs. I think it would be best if the default SVG search folder was not /home/myuser.

Also available in: Atom PDF